
Producer’s Best Friend
Producer’s Best Friend creates a formatted .xlsx spreadsheet report (for Numbers, Excel, 
Preview, etc.) about the video clips, audio clips, titles, generators, markers, keywords, effects 
and transitions in your edited timeline or Event to help you make batch lists, cut lists and 
music cue sheets. Producer’s Best Friend reports on Clips in a Library, Event, Compound Clip 
or Project. The report includes sheets for:

• Summary (with missing media and generators), 
• Clips (with optional thumbnails), 
• Roles/Subroles (with optional thumbnails), 
• Markers,
• Keywords and Ratings,
• Titles & Generators,
• Video & Audio Effects, and
• Transitions.

You can choose which roles to include in the report (Video, Titles, Dialogue, Music, Effects, 
and any roles and subroles you’ve created), and Preferences lets you choose whether times 
are displayed as frames, feet+frames, HH:MM:SS, seconds, or HH:MM:SS:FF timecode format.
Please use Email Support under the Help menu for bug reports, feature requests or support.

Compound Clips
With Compound Clips there are two reporting options:

• Report each Compound Clip to its own spreadsheet, treating the Compound Clip as 
another reportable timeline;

• Report Compound Clips by their component clips in the Project by breaking apart the 
Compound Clips.

If Compound Clips are present in the XML they will be available for selection and reporting in 
the Report pop-up menu. This will generate a report for the contents of the selected 
Compound Clip only.
A Compound Clip in a Project timeline is reported as if it were a single clip. To include the 
contents of Compound Clips within the Project report (as one report) then the Compound 
Clips must be broken apart into their original items.

Tip: The easiest way to locate your compound clips in a project is using the Timeline 
Index. In Final Cut Pro select multiple compound clips and choose Clip > Break Apart 
Clip Items before exporting the project XML from Final Cut Pro. You can break apart 
all Compound Clips in one action from the Timeline Index.



Loading XML into Producer’s Best Friend
1. In Final Cut Pro select a Library, 

Event or Project.
2. Choose the File menu and select 

Export XML… Choose a view from 
the Metadata View popup menu, 
and name and save the XML file. 
(See the tutorial at www.fcp.co/
final-cut-pro/tutorials/1542-the-
power-of-metadata-views-in-
final-cut-pro-x-by-philip-
hodgetts for more information 
about customizing metadata 
views.) Metadata fields with 
entries in a metadata view will be 
reported in the clips reports.

3. In Producer’s Best Friend, click 
the Open XML file… button or 
choose the File menu and select 
Open... to open the exported XML; 
or drag-and-drop the XML file to 
the dock tile.

Analyzing your Clips
1. Choose “All Library Clips”, an 

Event, a Project or a Compound 
Clip in the Report popup menu, 
then click the Analyze button.

2. Click the checkboxes 'on' for each 
video and audio role or subrole 
you want to include in the report.

3. Choose a Layout from the popup 
menu (see Preferences for more 
information).

4. To report only enabled clips, click the Enabled clips only radio button 'on'.
5. To add optional sheets to the report for summary, markers, keywords, titles/

generators, effects or transitions, click the appropriate checkboxes 'on'.
6. If you want the .xls file to open in your default spreadsheet application after the file 

is saved, click the Open the spreadsheet after saving checkbox 'on'.
7. Click the Save spreadsheet… button. Name and save the spreadsheet.

The spreadsheet can then be rearranged and customized, filtered, or the content of the 
spreadsheet copied and pasted into a pre-made template.
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Summary Report
For a Project or Compound 
Clip, lists all the roles/
subroles used in the timeline, 
missing media, and any non-
standard Effects/Transitions/
Titles/Generators (and 
highlights those that are 
missing). For a Library or 
Event, it also lists a summary 
of their Project’s names, 
durations, keywords and 
notes.  

Clips Report
Lists the video clips, audio clips, generators and titles for the chosen roles in timeline order. 
Depending on the chosen Layout, the report includes columns for: Video thumbnail, Role ▸ 
Subrole, Clip Name, Category (primary, secondary, connected); Enabled; Timeline In; 
Timeline Out; Clip Duration; Source In; Source Out; Source Duration; Duplicate Frames; 
Markers; Keywords; Effects; Notes; Reel; Scene; Take; Camera Angle; Camera Name; 
Frame Rate/Sample Rate; Frame Size/Audio Config; Source File Name; Source File Path; 
then columns for clip metadata. 

Tip: To report only the visible portion of used clips, overwrite connected video clips 
and secondary storylines into the primary storyline before exporting XML: duplicate 
your project or compound clip; select the secondary storylines and connected clips 
above the primary storyline (don’t select clips in the secondary storyline, select the 
storyline itself); choose Edit > Overwrite to Primary Storyline.  

Roles/Subroles Reports
A clips report sheet is created for each chosen role/subrole. Each sheet lists the clips for the 
chosen role in timeline order. (See Enhanced Reporting using Roles and Subroles.) The report 
includes the same columns as for the Clips Report. A Total for Source Duration is included at 
the bottom of the Source Duration column.



Keywords and Ratings Reports
Lists the clip keywords and shot analysis or favorite and rejected ranges in timeline order. 
(Favorites and rejected ranges only exist on clips in an Event, while keywords can be in an 
Event or Project.) For an Event, all ranges on each clip will be reported; for a Project, keyword 
ranges are limited to the part of the clip edited into the timeline (just like the Timeline Index). 
The report includes columns for: Keyword; Notes; Timeline In; Timeline Out; Duration; 
Clip Name; Role ▸ Subrole; Reel; Scene; Markers; then columns for clip metadata.

Markers Report
Lists the visible and hidden markers in timeline order. The report includes columns for: 
Marker Name; Type (Standard, Incomplete to-do, Completed to-do, or Chapter); Notes; 
Position; Clip Name; Role ▸ Subrole; Reel; Scene; Source In; Source Out; and Source 
Duration.

Titles & Generators Report
Lists the generators and titles for the chosen roles in timeline order. The report includes 
columns for: Name; Enabled; Apple (Apple vs non-standard generators); Role ▸ Subrole; 
Timeline In; Timeline Out; Clip Duration; Font; and Title Text.



Video & Audio Effects, Speed Change Effects Reports
Lists a summary of the built-in video effects (Color, Crop, Distort, Spatial Conform, 
Transform, Compositing), Effects Browser effects or Speed Change effects applied to clips for 
the chosen roles in timeline order. The report includes columns for: Effect name; On/Off; 
Apple (Apple vs non-standard effects); Clip Name; Role ▸ Subrole; Timeline In; Timeline 
Out; and Clip Duration. 

Transitions Report
Lists a summary of the transitions used in timeline order. The report includes columns for: 
Transition name; Category; Apple (Apple vs non-standard transitions); Timeline In; 
Timeline Out; and Duration.



Enhanced Reporting using Roles and Subroles
Roles provide enormous flexibility in reporting because you can create as many roles and 
subroles, as you need for detailed reporting. (See Create custom roles and subroles at 
help.apple.com/finalcutpro/mac/#verdbd5fbb, View and reassign roles at help.apple.com/
finalcutpro/mac/#verb71cbb80, and View clips by role in the Timeline at help.apple.com/
finalcutpro/mac/#verb71cb913.)
For example, if you want to generate music reports for each library source, then under the 
Music role create a subrole for each library: Music ▸ Music Bakery, Music ▸ Premium Beat, etc. 
(Naturally you’d substitute the actual names of your music libraries.)
Producer’s Best Friend will now generate a report sheet for each library including a total of 
the source durations used. (Sheet names can only be 31 characters long and contain 
restricted characters, so role names may be trimmed or altered.)
Similarly to track stock footage, create a Stock video role and then a subrole for each library: 
Stock ▸ Getty, Stock ▸ Pond 5, etc. (You will substitute the names of the footage libraries you 
actually use.)
Producer’s Best Friend will now generate a report sheet for each library, a total of the source 
durations used, and providing a clip list to order full resolution media.

Filtering reports in Excel
Excel has powerful features for filtering a spreadsheet. 

1. In Excel, choose the Data menu and select 
Filter. A popup menu indicator is added to 
the headings of the frontmost sheet.

2. To show only those rows where, say, the 
clip’s keyword is “Vineyard Shots”, click the 
Keywords popup menu indicator and select 
the keyword’s checkbox. The spreadsheet 
changes to show only those rows with the 
Vineyard Shots keyword.

3. For more powerful filtering, choose Data > 
Advanced Filter… from the popup menu. 
(See Excel’s help topic “Filter a list of data” 
for more information.)

Setting the application that 
opens spreadsheet documents

1. Select a .xlsx file in Finder and choose File > 
Get Info.

2. In the Open with: section choose your 
preferred application from the popup menu.

3. Click the Change All… button.  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Preferences
Choose the Producer’s Best Friend menu and select Preferences.

Layouts
You can create Layouts for clip reports that 
include only the columns you have selected. 
Click the “plus” button to name the new layout 
and add it to the popup menu, then turn on 
the checkboxes for the columns you want to 
include in the reports.

Click the “pencil” button to rename the layout; 
click the “minus” button to remove the layout. 
The default layout is Standard, which cannot 
be renamed or removed.
On OS X Mavericks or later you can choose to 
Add thumbnails at sizes from 40 to 640 
pixels wide. The thumbnail image is created 
from the clip’s in point, or for more control add a chapter marker and set the thumbnail pin 
to the image you want to use. (See Manage chapter markers and their thumbnail images at 
help.apple.com/finalcutpro/mac/#verc9cacc031 for details.)
Thumbnail images can only be created from AV Foundation-compatible media that is online.
For Final Cut Pro 10.4.9 or later, proxy media will be used to make thumbnail images if 
proxies have been generated. If the media is offline or incompatible, the thumbnail will be a 
“Missing” or “Unknown” graphic. Spreadsheets that include a column for thumbnails will be 
significantly slower to create.
Tip: Producer’s Best Friend running on Mac OS X 10.10 or later supports more media types 
(via AV Foundation) if the free “Pro Video Formats” are installed from this web page. You can 
check if you have Pro Video Formats installed by choosing Help > Check for Pro Video 
Formats.

http://help.apple.com/finalcutpro/mac/10.2/#/verc9cacc031
https://support.apple.com/kb/index?page=search&q=%22pro%20video%20formats%22&currentPage=1&includeArchived=false&locale=en_US&src=globalnav_support&type=suggested


Time Display
You can choose whether times are reported 
as Frames, Feet+Frames (4-perf at 24 fps), 
HH:MM:SS, Seconds, or HH:MM:SS:FF 
timecode format (drop frame or non-drop 
frame timecode will be used depending on 
the clip or timeline setting), or a combination 
of these. 
One or more time columns can be added to 
the report, and timeline times can be 
reported differently than source times.
For Timeline In and Timeline Out you can 
apply frame offsets to the reported times.

Text Colors
You can choose to have spreadsheet rows 
display as Colors (different text colors for 
video, audio, generators, titles, marker types, 
keywords and transitions based on Final Cut 
Pro’s color scheme) or Black-and-white. 


